If you were developing an iPhone App and were testing on iOS 4.0, and later if you did upgrade the device to 4.0.2, make sure you download iPhone SDK 4.0.2 to continue testing on the device.

Otherwise, you would get an error “No provisioned iPhone OS device is connected”.

Advertisements